Dedicated-Server.RU  


Ответ
 
Опции темы Опции просмотра
Старый 31.05.2013, 04:27   #31
Проверенный
 
Регистрация: 05.08.2012
Адрес: Russian
Сообщений: 133
Сказал спасибо: 95
Поблагодарили 37 раз(а) в 25 сообщениях
По умолчанию

Цитата:
Сообщение от DimaS Посмотреть сообщение
Поставил - MetaMod v1.20p36
Вот такие ошибки заметил в логах(Периодически падает, возможно из-за этого):
L 05/31/2013 - 03:22:21: [META] WARNING: ini: Plugin '<metamod_i386.so>' has newer file, but unexpected status (badfile)
L 05/31/2013 - 03:22:21: [META] WARNING: dll: Failed query plugin '<metamod_i386.so>'; Couldn't find Meta_Query(): cstrike/dlls/cs_i386.so: undefined symbol: Meta_Query
L 05/31/2013 - 03:22:21: [META] WARNING: dll: Skipping plugin '<metamod_i386.so>'; couldn't query

Есть варианты решения?
В папке /addons/metamod в plugins.ini случаем нету такой строки Linux addons/metamod/dlls/metamod_i386.so?
winzh1 вне форума   Ответить с цитированием
Пользователь сказал cпасибо:
Старый 31.05.2013, 07:05   #32
Проверенный
 
Регистрация: 19.12.2002
Адрес: Kazan
Сообщений: 210
Сказал спасибо: 4
Поблагодарили 92 раз(а) в 33 сообщениях
По умолчанию

пытаемся загрузить метамод метамодом, рекурсия...
нужно убрать лишнее из ini файла.
rulezzzik вне форума   Ответить с цитированием
2 пользователей сказали cпасибо:
Старый 01.06.2013, 10:36   #33
Журналист
 
Регистрация: 24.03.2012
Адрес: spb
Сообщений: 1,433
Сказал спасибо: 554
Поблагодарили 722 раз(а) в 280 сообщениях
По умолчанию

Цитата:
Сообщение от winzh1 Посмотреть сообщение
В папке /addons/metamod в plugins.ini случаем нету такой строки Linux addons/metamod/dlls/metamod_i386.so?
Цитата:
Сообщение от rulezzzik Посмотреть сообщение
пытаемся загрузить метамод метамодом, рекурсия...
нужно убрать лишнее из ini файла.
Благодарю за столь быстрый ответ.
Видимо с другими модулями засунул :)
Спасибо.(решено)
DimaS вне форума   Ответить с цитированием
Старый 04.06.2013, 07:57   #34
DS.RU Moderator
 
Регистрация: 26.03.2004
Адрес: Москва
Сообщений: 2,751
Сказал спасибо: 9
Поблагодарили 93 раз(а) в 39 сообщениях
По умолчанию

Как я вижу народ смелый подтянулся, есть вопросы по поводу CentOS , на версии 6.4 GLIBC 2.12, обновлять в репе не хотят, постоянно ищут причины, хотя федора и RH уже сидят на 2.17 , так вот в инете дует ветром по поводу попытки обновления и смерти после обновления, вопрос так ли это и если кто пробовал обновить просьба выложить рекомендации, в линуксе как свинья в апельсинах и нужен FAQ по теме обновления GLIBC с 2.12 на 2.15 (хотябы...)

Отправлять в гугель не стоит, ибо если нечего сказать или написать то лучше молчать и сопеть в две дырки, в портале помощь должна быть за углом, а не в помойке...
__________________
© Специалист по выносу мозга...
© [DEAGLE.RU] - Комитет по борьбе с читерами.
------------------------------------------------
Клиент + update cs1.6 V43
Блокируем сегменты сети по маскам, также бан подсетей MTU-INTEL через плагин AMXX
Консольные команды CS Source и HL2
Да, был знаком с DeadMoroz в 1999 и что ?
Да, ломали защиту Sierra в 1999 и выпустили первого клиента CS и что ?
Да, был знаком с MaddoxEmporio и что ?
Да, делал сборки и патчи на CS и что ?
western вне форума   Ответить с цитированием
Пользователь сказал cпасибо:
Старый 04.06.2013, 08:14   #35
Проверенный
 
Регистрация: 19.12.2002
Адрес: Kazan
Сообщений: 210
Сказал спасибо: 4
Поблагодарили 92 раз(а) в 33 сообщениях
По умолчанию

Цитата:
Сообщение от western Посмотреть сообщение
Как я вижу народ смелый подтянулся, есть вопросы по поводу CentOS , на версии 6.4 GLIBC 2.12, обновлять в репе не хотят, постоянно ищут причины, хотя федора и RH уже сидят на 2.17 , так вот в инете дует ветром по поводу попытки обновления и смерти после обновления, вопрос так ли это и если кто пробовал обновить просьба выложить рекомендации, в линуксе как свинья в апельсинах и нужен FAQ по теме обновления GLIBC с 2.12 на 2.15 (хотябы...)

Отправлять в гугель не стоит, ибо если нечего сказать или написать то лучше молчать и сопеть в две дырки, в портале помощь должна быть за углом, а не в помойке...
на работе сегодня поставлю на виртуалку 6.4, и попробую обновить.
rulezzzik вне форума   Ответить с цитированием
Старый 04.06.2013, 11:53   #36
Проверенный
 
Регистрация: 19.12.2002
Адрес: Kazan
Сообщений: 210
Сказал спасибо: 4
Поблагодарили 92 раз(а) в 33 сообщениях
По умолчанию

Поставил минималку, поставил глибц 2.15 рпм ничего плохого не произошло, можно самому проверить на локальной виртуалке и попробывать запустить сервер
rulezzzik вне форума   Ответить с цитированием
Старый 04.06.2013, 16:46   #37
с доступом к форуму безопасности
 
Регистрация: 03.03.2012
Адрес: Махачкала
Сообщений: 288
Сказал спасибо: 270
Поблагодарили 62 раз(а) в 45 сообщениях
По умолчанию

rulezzzik,можеш выложить сам rpm 2.15? В инете никак не найду его под centos
Kain_wrath вне форума   Ответить с цитированием
Старый 04.06.2013, 20:00   #38
DS.RU Moderator
 
Регистрация: 22.02.2003
Адрес: Россия/Москва
Сообщений: 2,227
Сказал спасибо: 135
Поблагодарили 116 раз(а) в 82 сообщениях
По умолчанию

пакет от федоры скорее всего подойдет
__________________
Old school gamers is played like that !
fresh-meat.ru:27015 Counter-Strike - myAC 1.6 REG
fresh-meat.ru:27017 Condition-Zero - myAC 1.6 REG
fresh-meat.ru:7771 Unreal tournament 3 Deathmatch server
fresh-meat.ru Dual Xeon X5570/16Gb RAM / CentOS Linux 7.1
Slayer[605] вне форума   Ответить с цитированием
Старый 05.06.2013, 13:47   #39
с доступом к форуму безопасности
 
Регистрация: 03.03.2012
Адрес: Махачкала
Сообщений: 288
Сказал спасибо: 270
Поблагодарили 62 раз(а) в 45 сообщениях
По умолчанию

скорее всего подойдет, не подойдет т.к. ставлю не я а админ сервера, а он экспериментировать с системой не хочет, поэтому прошу выложить тот который нормально завелся
Kain_wrath вне форума   Ответить с цитированием
Старый 06.06.2013, 14:31   #41
DS.RU Moderator
 
Регистрация: 26.03.2004
Адрес: Москва
Сообщений: 2,751
Сказал спасибо: 9
Поблагодарили 93 раз(а) в 39 сообщениях
По умолчанию

Если rpm -i glibc-2.15-22.6.4.i686.rpm
куча таких записей
файл /usr/bin/locale из устанавливаемого пакета glibc-2.15-22.6.4.i686 конфликтует с файлом из пакета glibc-common-2.12-1.107.el6.i686
__________________
© Специалист по выносу мозга...
© [DEAGLE.RU] - Комитет по борьбе с читерами.
------------------------------------------------
Клиент + update cs1.6 V43
Блокируем сегменты сети по маскам, также бан подсетей MTU-INTEL через плагин AMXX
Консольные команды CS Source и HL2
Да, был знаком с DeadMoroz в 1999 и что ?
Да, ломали защиту Sierra в 1999 и выпустили первого клиента CS и что ?
Да, был знаком с MaddoxEmporio и что ?
Да, делал сборки и патчи на CS и что ?
western вне форума   Ответить с цитированием
Старый 18.10.2013, 23:01   #42
Эксперт
 
Регистрация: 20.08.2005
Адрес: Moscow
Сообщений: 3,649
Сказал спасибо: 197
Поблагодарили 236 раз(а) в 164 сообщениях
По умолчанию

а кто-нибудь компилировал? думаю в тему можно добавить
полезно для тех,кто использует данный модуль
https://github.com/Arkshine/Orpheu
__________________
HLDS protocol 48 (CS 1.1.2.6 build 4883 on FreeBSD 9.0)
AMXX v1.8.1.3746 | METAMOD v1.19p32 | DProto 0.9.87
Web: Nginx 1.0.10 (build 1.1), Apache 2.2.21, PHP 5.3.8, MySQL 5.5.17
----------------------------
интересно для временного общения: chat 1 chat 2 chat 3
----------------------------
Client 1.6 v43 (4554) от Western'a
Обсуждение тут
Клиент на DS.ru(по 3 файла)
----------------------------
HLTV
----------------------------
Metamod & Metamod-P
Metamod-p && amxmodx builds
----------------------------
My Plugs
No Reconnect
CS: GO List
Message Logging
----------------------------
Steam API:XML,JSON (поменять IP:PORT на свои)
или сайт
Z@C вне форума   Ответить с цитированием
2 пользователей сказали cпасибо:
Старый 18.10.2013, 23:52   #43
с доступом к форуму безопасности
 
Регистрация: 07.05.2012
Адрес: Ярославль
Сообщений: 215
Сказал спасибо: 162
Поблагодарили 35 раз(а) в 26 сообщениях
По умолчанию

Цитата:
Сообщение от Z@C Посмотреть сообщение
а кто-нибудь компилировал? думаю в тему можно добавить
полезно для тех,кто использует данный модуль
https://github.com/Arkshine/Orpheu
Это наверное самый требующий оптимизации модуль))) На фоне последних обновлений движка актуальность только растет... Еще бы rage...
f1nik вне форума   Ответить с цитированием
Старый 20.10.2013, 22:44   #44
Проверенный
 
Регистрация: 16.02.2012
Адрес: Москва
Сообщений: 650
Сказал спасибо: 251
Поблагодарили 84 раз(а) в 72 сообщениях
По умолчанию

f1nik,
этот модуль самый неоптимизируемый в принципе....
он ничего такого особого не делает. патч памяти и все.

Странно то, что этот модуль компилить то не хотят... =/
neygomon вне форума   Ответить с цитированием
Старый 21.10.2013, 08:15   #45
Проверенный
 
Регистрация: 19.12.2002
Адрес: Kazan
Сообщений: 210
Сказал спасибо: 4
Поблагодарили 92 раз(а) в 33 сообщениях
По умолчанию

Код посмотрел, действительно там всего пару моментов есть за которые зацепится можно, но от оригинала разница небольшая будет, если настаиваете, скомпилю и выложу.
rulezzzik вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 14:01. Часовой пояс GMT +3.


Лицензия принадлежит Dedicated-Server.Ru